Cấu hình IPTV Viettel trên MikroTik

Mô hình dịch vụ Internet và dịch vụ My Tivi (IPTV) đã được các ISP Việt Nam tích hợp chung trên một đường truyền cáp quang và đã triển khai từ lâu, nhưng với Router nhà mạng thường không đủ tài và hay bị treo. Vì vậy người dùng cần phải thay Router mạnh hơn .

Bài viết dưới đấy hướng dẫn người dùng thiết lập dịch vụ IPTV trên thiết bị Router MikroTik.

Bài viết nầy thực hiện trên Router MikroTik RB3011UiAS, là thiết bị chuyên dụng chạy Loadbalancing Fail Over nhiều WAN, Hotspot Gateway, Firewall...v.v. Có khả năng chịu tải lên đến 300 User đồng thời 

Với ISP Viettel thông thường chạy dịch vụ internet trên Vlan 35 và dịch vụ IPTV trên Vlan 2502

Mô Hình : 

 

 

Số lượng Set Top Box tùy bạn đăng kí với nhà mạng tương ứng với số Tivi mà bạn cần sử dụng 

Trước khi cấu hình quay PPPoE trên MikroTik thì bạn phải chuyển Router nhà mạng thành Brigde Mode, nếu chưa chuyển hoặc chưa cấu hình PPPoE lần nào trên MikroTik thì tham khảo bài viết ở đây 

Cấu hình trên Router MikroTik

Bước 1: Add Vlan 

/interface vlan
add interface=ether1 name=vlan-IPTV vlan-id=2502
add interface=ether1 name=vlan35-Viettel vlan-id=35

 

Bước 2: Tạo Brigde để add các Vlan chạy IPTV và quay PPPoE 

/interface bridge
add igmp-snooping=yes name=IPTV-Viettel
/interface bridge port
add bridge=IPTV-Viettel interface=vlan35-Viettel
add bridge=IPTV-Viettel interface=vlan-IPTV
add bridge=IPTV-Viettel interface=ether9
add bridge=IPTV-Viettel interface=ether10

 

Bước 3: Quay PPPoE và Kết nối Set Top Box

/interface pppoe-client
add add-default-route=yes disabled=no interface=IPTV-Viettel name=pppoe-Viettel password=8BTxxx user=t008_gftth_abcwxzx

 

 

Khi chúng ta quay PPPoE thành công nghĩa là dịch vụ IPTV đã hoạt động, bây giờ kết nối hai Port Access 9&10 vào Set Top Box kiểm tra kết quả.

 

 

Bổ sung thêm 

Trường hợp nầy là add Vlan vô là chạy được IPTV một số nhà mạng chạy Broadcast thì ta phải cài thêm gói IGMP Protocol  (Internet Group Management Protocol ) nằm trong gói Packet Multicast, khi đó chúng ta phải add Firewall Rule 

KẾT THÚC 

Bạn đọc gặp khó khăn trong quá trình triển khai hoặc cần tư vấn Network, WiFi Unifi, WiFi Maketing, cấu hình thiết bị Mikrotik vui lòng liên hệ contact bên dưới .

CTY CNTT MINH ANH

VPGD: 05 Trương Công Định, Phường 14, Quận Tân Bình, TP HCM

ĐT: 028.3811 3439

Hotline: 0918 148 137